WeBid Bug Tracking

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000459WeBidAuctionspublic2013-11-01 23:092017-07-21 10:49
Assigned Torenlok 
Priority@0@SeverityminorReproducibilityhave not tried
PlatformOSOS Version
Product Version 
Target Version1.2.0Fixed in Version 
Summary0000459: After automatic relisting ended, manual renew had a 1970 closed date
DescriptionThis may be a bug - I'm not sure.

One of the sellers on my site, www.hatatorium.com/emporium-new/ had 3 listings expire after several automatic relists. She went into closed listings and checked the boxes to relist, after which the items showed up in open auctions, but each had a notation saying it was closed, with a 1970 date. I told her to go into the control panel and close them, then relist them again, and it worked. They showed up in open auctions with the correct ending date.

I have never had this happen to my own listings. She had a similar problem once before, with the item that had closed not showing up in closed listings at all, but I went into the admin back end and found it in closed auctions and deleted it, after which it showed up in her closed auctions and she was able to relist.

The weird thing is we've been active for several months and these two times are the only times it has happened.

I looked in my error log and found an unusual error message that coincides with the approximate time she encountered the problem.

28-10-2013, 09:13:05: Database access error. Please contact the site administrator. SELECT a.current_bid, a.id, a.title, a.ends, b.bid, b.quantity FROM webid_bids b LEFT JOIN webid_auctions a ON (a.id = b.auction) WHERE a.closed = 0 AND b.bidder = AND a.bn_only = 'n' ORDER BY a.ends ASC, b.bidwhen DESC You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND a.bn_only = 'n' ORDER BY a.ends ASC, b.bidwhen DESC' at line 4 page:/home/public_html/hatatorium.com/emporium-new/yourbids.php line:24

I would appreciate any advice or suggestions.

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
DrJ (reporter)
2013-11-02 02:19
edited on: 1970-01-01 00:00

I have had similar issues but only with a few listings, similar to your results. This has only happened in 4 or 5 of over 650 auctions. So I have not been able to narrow down the issue. Instead of requiring my user to delete and relist, I just changed the "Ending" date in the database. I am still researching as I get time but like you, I would appreciate any help.
bgrantland (reporter)
2014-01-15 04:03
edited on: 1970-01-01 00:00

This error occurred again today. Pam, the same seller who had this error before, relisted some items and then edited them to make them BIN only. One of the edited listings showed up as an active listing, but with a closed notation and a 1970 end date. I found the item in the administrative back end and edited it. First I noticed it had a opening bid price of $35 and she had added a BIN only of $35. I deleted the opening bid price and saved it, and got an error message saying a field was left empty. I went back and changed the opening bid price to $35 and it saved correctly with a correct end date.

I don't know if this is relevant to the same problem or not, but a couple of days ago I was changing my old listings to BIN only and when I went to save one of them I had an error message saying "can't begin auction in the past." I went back and checked and the box for "begin auction now" was no longer checked. I checked it and it saved and updated properly.
jackworm (viewer)
2014-01-15 17:13
edited on: 1970-01-01 00:00

The 1970 part is probably the system not being able to get the current time (dates in php are start from the Unix start time in 1970. 1st of Jan I think)

Was the auction set to close the number of days the user set, from 1/1/1970?
Not had this problem yet, but would be good if someone could look in the php/apache error log.....?

As for error in the sql on the first line, that is to do with not being able to retrieve the user ID when accessing the table (probably be a system->user or user-> id error, not sure which is used in that file) Again, difficult with not much info, but I don't think its relevant to the 1970 bug
nay27uk (reporter)
2014-01-15 17:50
edited on: 1970-01-01 00:00

Yep this is an old WeBid problem from way back in version 0.8.4 where every listed item was being posted with a date of 1970 and as a result they are automatically closed.

The problem was resolved but must have been over looked in follow up versions.

If you search the forum for the term 1970 you will find all the old threads about it.

I remember this happening to me on 1.0.1 as well and forgot to post it up.

I can confirm this is a bug so will add this to the bugs section for you.
bgrantland (reporter)
2014-01-20 20:20
edited on: 1970-01-01 00:00

jackworm wrote

Was the auction set to close the number of days the user set, from 1/1/1970?

No, when this 1970 start date appears, the item shows up in active listings with the notation Closed. It has to be deleted or edited through the admin back end. It doesn't happen very often, and for some reason it has only happened to one of my sellers. It has never happened to my listings.
david62311 (reporter)
2014-02-11 20:29
edited on: 2014-02-12 00:30

Whoops...posted in the wrong 1970 thread. Sorry.
pani100 (reporter)
2014-02-11 21:25
edited on: 2014-02-11 21:26

@ Brenda, Hi ,
on your error it is telling us that the $user->user_data['id'] has no value which is impossible as to get to the query it has to pass if (!$user->is_logged_in()) which gets all the user details and stores in the $user class. This is going to be a tricky one to find what is causing it. One thing I would do is go in the yourbids.php and remove all the whitespace after the last ?> . White space has been known to cause a few problems. To such a degree some scripts now don't include the last closing tag at all (the use of ?> at the end of a file is completely optional)
david62311 (reporter)
2014-02-12 00:48
edited on: 2014-02-13 02:10

What version are you using? They made some changes in the includes/functions_sell.php page when they updated from the 1.1.0 version to the 1.1.1 version. If you haven't tried the 1.1.1 page then give it a try and let us know if you still have the problem.
bgrantland (reporter)
2014-02-18 18:18
edited on: 1970-01-01 00:00

Thanks Pani. I removed the blank line at the end of yourbids.php, and we'll see what happens. The bug happened so rarely that it may take a long time to confirm that it is fixed.

By the way I checked and the blank line at the end was in the original unmodded version of 1.1.1, so if that was causing the problem others will eventually see it too probably.
bgrantland (reporter)
2014-02-18 20:40
edited on: 1970-01-01 00:00

In answer to your question, David, I'm using version 1.1.1.

- Issue History
Date Modified Username Field Change
2015-04-01 13:17 renlok New Issue
2015-04-01 13:17 renlok import_id => 461
2015-04-01 13:17 renlok Date Submitted 2015-04-01 13:17 => 2013-11-01 23:09
2015-04-01 13:17 renlok Last Update 2015-04-01 13:17 => 2014-02-18 20:40
2016-04-24 14:16 renlok Target Version => 1.2.0
2016-11-23 11:03 renlok Status confirmed => resolved
2016-11-23 11:03 renlok Resolution open => fixed
2016-11-23 11:03 renlok Assigned To => renlok

Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker