WeBid Bug Tracking

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000485WeBid[All Projects] Generalpublic2014-05-29 19:032015-02-17 10:25
ReporterGrinfeld 
Assigned To 
Priority@0@SeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version1.1.1 
Target VersionFixed in Version1.1.2 
Summary0000485: Thumbnail image not showing at end of auction no winer email
DescriptionHello to all,



The thumbnail image (of the corresponding auction) at the end of auction no winer email does not show in the emails send by WeBid. Instead it only shows the default_item_img.jpg. Located in images/email_alerts/default_item_img.jpg.



In file: /language/EN/emails/html/endauction_nowinner.inc.php the line indicating the src for the thumbnail auction image shows the following code:



<td width="9%" rowspan="2"><div align="center"><img width="120" border="0" src="{A_PICURL}"></div></td>



{A_PICURL} is define in /includes/endauction_nowinner.inc.php as follows:



'A_PICURL' => ($pict_url != '') ? $system->SETTINGS['siteurl'] . $uploaded_path . $auction_id . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',



Does any body knows where the code problem is?



Thanks a lot!

Mario Grinfeld
TagsNo tags attached.
import_id501
Thread
Attached Files

- Relationships

-  Notes
(0001322)
pani100 (reporter)
2014-05-29 20:44
edited on: 1970-01-01 00:00

Grinfeld;39013 wrote

Hello to all,

The thumbnail image (of the corresponding auction) at the end of auction no winer email does not show in the emails send by WeBid. Instead it only shows the default_item_img.jpg. Located in images/email_alerts/default_item_img.jpg.

In file: /language/EN/emails/html/endauction_nowinner.inc.php the line indicating the src for the thumbnail auction image shows the following code:

<td width="9%" rowspan="2"><div align="center"><img width="120" border="0" src="{A_PICURL}"></div></td>

{A_PICURL} is define in /includes/endauction_nowinner.inc.php as follows:

'A_PICURL' => ($pict_url != '') ? $system->SETTINGS['siteurl'] . $uploaded_path . $auction_id . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',

Does any body knows where the code problem is?

Thanks a lot!
Mario Grinfeld

Hi Mario,
 Suspect this email is used from the cron.php where all our vars are under $Auction. There is something not right with the 'A_PICURL' =>...
I think it should be

'A_PICURL' => ($Auction['pict_url'] != '') ? $system->SETTINGS['siteurl'] . $uploaded_path . $auction_id . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',

or even better

'A_PICURL' => (!empty($Auction['pict_url'])) ? $system->SETTINGS['siteurl'] . $uploaded_path . $auction_id . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',
- empty first checks to see if the var is set, avoiding an error message if it is not set or does not exist
(0001323)
Grinfeld (reporter)
2014-05-29 21:51
edited on: 1970-01-01 00:00

pani100;39015 wrote

Hi Mario,
 Suspect this email is used from the cron.php where all our vars are under $Auction. There is something not right with the 'A_PICURL' =>...
I think it should be

'A_PICURL' => ($Auction['pict_url'] != '') ? $system->SETTINGS['siteurl'] . $uploaded_path . $auction_id . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',

or even better

'A_PICURL' => (!empty($Auction['pict_url'])) ? $system->SETTINGS['siteurl'] . $uploaded_path . $auction_id . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',
- empty first checks to see if the var is set, avoiding an error message if it is not set or does not exist


Hi Pani, thanks again. We are almost there! When I look at the src path in the email I received is almost complete but is missing the auction ID, so the email does not show the thumbnail image yet. Here is the source in the email missing the ID:

 src="http://www.grinfeld.com/fine-arts-auctions-subastas-de-arte-online/uploaded//2485ElTobiano.jpg" [^]

How should I correct the code? I am using the second option you gave me:

'A_PICURL' => (!empty($Auction['pict_url'])) ? $system->SETTINGS['siteurl'] . $uploaded_path . $auction_id . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',

Best to you,
Mario
(0001324)
nay27uk (reporter)
2014-05-29 22:02
edited on: 1970-01-01 00:00

take out the extra / in the php as it is adding it to the picture URL and thats why it is not showing the picture
src="/2485ElTobiano.jpg"">http://www.grinfeld.com/fine-arts-auctions-subastas-de-arte-online/uploaded//2485ElTobiano.jpg" [/2485ElTobiano.jpg"" target="_blank">^] notice the extra / in green.

you need to take out the '/' bit in the above php code
(0001325)
Grinfeld (reporter)
2014-05-29 22:10
edited on: 1970-01-01 00:00

Hi Nay!!! Yes I noticed that, but still the code is not giving me the auction ID. The auction ID which is in the uploaded folder for each auction... that id in this case, I now, is 3 and is the one that should be between the two / so instead of being:

http://www.grinfeld.com/fine-arts-auctions-subastas-de-arte-online/uploaded//2485ElTobiano.jpg[/url] [^]

should be:

http://www.grinfeld.com/fine-arts-auctions-subastas-de-arte-online/uploaded/3/2485ElTobiano.jpg[/url] [^]

so we are missing something in the following code to show the auction ID:

'A_PICURL' => (!empty($Auction['pict_url'])) ? $system->SETTINGS['siteurl'] . $uploaded_path . $auction_id . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',

Thanks again,
Mario
PD: By the way take a look at the picture of the auction is such a good work of art
(0001326)
pani100 (reporter)
2014-05-29 22:54
edited on: 1970-01-01 00:00

Grinfeld;39016 wrote

Hi Pani, thanks again. We are almost there! When I look at the src path in the email I received is almost complete but is missing the auction ID, so the email does not show the thumbnail image yet. Here is the source in the email missing the ID:

 src="http://www.grinfeld.com/fine-arts-auctions-subastas-de-arte-online/uploaded//2485ElTobiano.jpg" [^]

How should I correct the code? I am using the second option you gave me:

'A_PICURL' => (!empty($Auction['pict_url'])) ? $system->SETTINGS['siteurl'] . $uploaded_path . $auction_id . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',

Best to you,
Mario

Ok, Try
'A_PICURL' => (!empty($Auction['pict_url'])) ? $system->SETTINGS['siteurl'] . $uploaded_path . $Auction['id'] . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',
(0001327)
Grinfeld (reporter)
2014-05-30 02:17
edited on: 1970-01-01 00:00

pani100;39021 wrote

Ok, Try
'A_PICURL' => (!empty($Auction['pict_url'])) ? $system->SETTINGS['siteurl'] . $uploaded_path . $Auction['id'] . '/' . $Auction['pict_url'] : $system->SETTINGS['siteurl'] . 'images/email_alerts/default_item_img.jpg',


I tried your suggestion. It works great! Thank you Pani100, I want you to know I greatly appreciate your dedication and hard work. I have been working on this project for the last two years and I am very happy about it. The support I have received from this forum has been and it is excellent.

Best of the best,
Mario
(0001328)
pani100 (reporter)
2014-05-31 20:51
edited on: 1970-01-01 00:00

No problem Mario. Happy to help
(0001329)
nay27uk (reporter)
2015-02-01 13:10
edited on: 1970-01-01 00:00

A note for anyone adding this to the 1.1.1 for the bug fixes thread.

This is done in the file includes/email_endauction_nowinner.php rather than in the cron.php as pointed out above

- Issue History
Date Modified Username Field Change
2015-04-01 13:17 renlok New Issue
2015-04-01 13:17 renlok import_id => 501
2015-04-01 13:17 renlok Date Submitted 2015-04-01 13:17 => 2014-05-29 19:03
2015-04-01 13:17 renlok Last Update 2015-04-01 13:17 => 2015-02-17 10:25


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker